Forum

You need to log in to create posts and topics.

[solved] Pi3B + DAC2 + AMP10, does not work anymore

hi,

i have been using volumio in the above configuration for about 3 months. but when i turn on the system today, both the screen does not work and there is no sound for the speakers. the problem was not solved when I installed pi4 instead of pi3b. it didn't work to reinstall volumio and make all the settings again. currently the latest version of volumio is installed (2,799).

But something happened to my attention;

volumio@volumio:~$ cd /home/volumio/nanosound_oled

volumio@volumio:~/nanosound_oled$ python nanodac_oled.py

Traceback (most recent call last):

  File "nanodac_oled.py", line 7, in <module>

    from luma.oled.device import ssd1306, ssd1325, ssd1331, sh1106

ImportError: No module named oled.device

What would you suggest me do?

Have you tried uninstall and reinstall the nanosound plugin?

Thanks.

Yes. I even tried it several times and in a few different ways.

Hi,  we will take a deeper look.  Please give us a couple of days to test.

 

Thanks.

Found the solution, please run below before starting the plugin.  We will put the fix into the plugin code.

thanks for raising this!

 

sudo -H pip install --upgrade luma.core==1.13.0 luma.oled==3.4.0

PR: https://github.com/volumio/volumio-plugins/pull/460

Thank you. Everything is OK, 🙂

with 'sudo -H pip install --upgrade luma.core==1.13.0 luma.oled==3.4.0'