Forum

Please or Register to create posts and topics.

[Resolved] CD rip to USB - Access rights issue ? "cd extraction aborted please try again"

Hi Team,

I am using the apple external CD Drive on my raspberry pi.  Using Volumio I am able to use Nanosound CD to play the CD.  I have also paid for the upgrade.  And I am able to rip to the 'INTERNAL' storage of the Pi.

The problem I have, is when I set the storage path to being the USB drive.  I'm pretty sure my Path is correct - But when I 'Check Extraction Process' I get the red box in the top right hand corner of "cd extraction aborted please try again".

I beleive that this is a user account issue - That the the Volumio Account / Nanosound account (?) does not have write access to the USB storage.

What user account should I use to set the access for ? Any pointers please ?  I'm not strong in Linux Command line - So any pointers on the command to use would be great.

Thanks!

Hi,

Can you please try this?

enable ssh access via http://volumio.local/dev

login to volumio.local with putty.

login as: volumio

password: volumio

make sure your usb drive is mounted by using below to check

df -Th

Make sure it's mounted to /media

cd /media

touch dummy

Above will test the write access.

 

 

 

Thanks for the feedback !

I fear I'm reaching my limits - But the mounting of the USB looks to be part of the issue.  When running the tests as instructed the dummy file was created - But I think the drive is mounted incorrectly ???  Attached is a low tech photo as I dont currently have access to Putty/Similar.

 

Also - I have attached a screen grab of the folders that my LMS can see - and hopefully tells more of the story of the mounting of the USB storage.

 

My intended use is to rip using Nanosound CD - Then play/stream using Logitech Media server and numerous players / Google devisces.

Uploaded files:
  • 20210530_100817.jpg
  • LMS-USB-Mount.JPG

I did some more research on Mounting / Rights.  And followed this tutorial to create a folder/mount for the Volumio user to have access:

How To Mount A USB Flash Disk On The Raspberry Pi

So far - This allows me to rip the files to the root of the USB storage - But I'm not able to place the files into the \music folder.

Attached is the screenshot of what is currently working.  But I'd prefer if it could drop the files into \music.  When I set the location to be USB/usb - Nanosound CD allows it.  When I set the folder to be USV/usb/Music - Nanosound  CD states that there is no folder of that name available.

Can you create the music folder and make sure its writable so that it can be available for saving?

 

 

Thanks for the reply - I have been able to resolve the issue - I needed a couple of attempts to identify the correct path to the folder on the USB that I wanted to write to.

Thank you for the response.  I'm still not fully aware what the cause was - since the 'Touch' test worked.  But adding in the mounting instructions as per the web page instructions on bootup worked.

Have a great day !