Forum

Please or Register to create posts and topics.

CD Playback okay but volumio playback silent (Resolved)

I just received the DAC 2 PRO.

I am able to hear the CD playback through the Pioneer DVD and NanoSound CD.

However, all stored music (both FLAC and wav) and the web radio stations I've tried do have any sound.  Volumio looks like it is going through the motions of playing the content (web radio titles appear and are replaced; tracks get queued and play to the next track) but nothing is heard.  This is my first unit but one of the settings seems to indicate that there should be a startup sound -- I don't hear that either.

I'm using a headphone.  I don't have any RCA speakers and I can't get the wired speakers to connect to the jacks on the AMP^2 board (I'll leave that for another message).

Volumio version: 2.572
Output device:  NanoSound DAC
I2SDAC:  On
DAC Model:  NanoSound DAC

General Playback Options:
DSD Playback Mode:  DSD Direct
DSD Auto Volume Level: Off
Volume Nomalization: Off

Volume Options:
Mixer Type: Hardware
Mixer Control Name: Digital
Default Startup Volume: 45
MPD Client Volume Control: Off

Audio Resampling: Off

What should I do?

Hi Curtis,

Please follow below procedure to test:

-  do a clean reboot (power off and on).

- Does the green light above the screen light up during start up and light off after reboot ?

- After it's fully booted, play any song files, does the green light turned on?

If you dont see the green light turned on when playback try this:

- In playback options,

- Turn I2S DAC Off

- Reboot

- After reboot, go back to playback options

- choose Output Device and DAC model as "NanoSound DAC"

Try to play files again.

Also:

- Did you use the sd card which came with the kit?

- Did you connect the Amp^2 correct as in https://nanomesher.com/nanosound-amp2-support/?

Regards,

Nanomesher

It works now!

The OLED is dark after the splash screen goes away and it stays dark even during playback.  I'll talk about that in a separate message.

For lurkers, this is what I did:

These instructions are probably not the most efficient way to solve the problem but it's what I did to get control of the DAC2 and get success.

After posting the above message, I "tried things" to see what would happen.  In addition to the configuration specified in the first message, I had it in this configuration:

Make sure at least one ripped song is in the Queue.

DSD Playback Mode (under General Playback Options):  DSD over PCM (DoP)
Save (in the General Playback Options)

Audio Output:
Output Device:  Audio Jack
I2S DAC: Off
DAC Model: Adafruit MAX98357   // yes, this is wrong but that's what I had
Save (in the Audio Output section)

The DAC2 will reboot.

Turn off the DAC2 (press and hold the power button for at least 4 seconds).
When it is done powering down, remove power for 10 seconds or more.

Plug the DAC2 back in.

Power-up the DAC2.

I heard a static "pop" in the headset again that coincided with the OLED splash screen.

The OLED splash screen showed the first item in my queue.

Press "play" in the top menu.

Playback had no audio.  The OLED screen showed the playback occurring and the play time was incrementing.

Set the General Playback Option / DSD Playback Mode to DSD Direct, then hit the Save button in that section.

Note: pressing Save in the top Audio section will cause the DAC2 to restart -- you don't want that just yet.

Set the DAC Model to NanoSound DAC
Set the Output Device to NanSound DAC
Set the I2S DAC to On
Save

After seeing the notification that the "Player successfully restarted", power off the DAC2, unplug it, then wait 10 seconds and reapply power and power up the DAC2.

I did not hear a "pop" when the splash screen appeared but the green light turned on shortly after the splash screen, and I heard a series of tones (for the first time) shortly before the splash screen went dark.  The green light went off shortly after the splash screen went dark.

Go to your Queue.  Play any song, either in wav or flac format.  It works!

To answer Nanomesher's questions:
1) Yes, I used the SD card that came with the kit.
2) I did connect the Amp^2 according to the instructions (being careful to put the offset washers in the right place)

CurtisK

Glad that it works.

 

The oled has a software timer which turn off after 3 mins of lack of playback activity.

It should turn on automatically when playback starts.

Thanks

 

 

Hmm.  That's not what I'm seeing.  I'll start a new thread about this.

Is the nanosound plugin enabled?

You may refer to the "configuration for yor DAC" section in https://nanomesher.com/support/nanosound-support/

Thank you

I am experiencing same concern before and because of this thread, I resolve it instantly. Thank you so much for all the comments here. And if some of you are interested to play games just visit gra oszusta and https://grannygame.io/