Forum

Please or Register to create posts and topics.

CD / DVD drive not detected

So as the title says, I had to factory reset volumio again due to mpd not working properly, and after reinstalling nanosound cd, then using the reconfig audio button in the plugin's settings, I rebooted, but now it says "Cannot detect CD / DVD drive or no CD in the tray".

 

Another thing worth noting: when I click on the eject cd tray button on the plugin's settings, it does eject the tray of my drive. So it's "seeing" something I assume, but for some reason it won't get the list anymore.

 

I also tried another audio CD that I know worked fine on this same setup. Then unplugged the CD drive and plugged it back in. Same result.

 

Here's the output of dmesg and ls in the cdrom device, in case they help:

volumio@volumio:~$ ls /dev/cdrom
/dev/cdrom
volumio@volumio:~$ ls -alh /dev/cdrom
lrwxrwxrwx 1 root root 3 Jun 17 13:05 /dev/cdrom -> sr0
volumio@volumio:~$ ls /dev/sr0
/dev/sr0
volumio@volumio:~$ ls -alh /dev/sr0
brw-rw---- 1 root cdrom 11, 0 Jun 17 13:05 /dev/sr0
volumio@volumio:~$

 

[ 6.702232] usb 1-1.3: new high-speed USB device number 6 using dwc_otg
[ 6.833064] usb 1-1.3: New USB device found, idVendor=152d, idProduct=2338, bcdDevice= 1.00
[ 6.833076] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[ 6.833085] usb 1-1.3: Product: USB to ATA/ATAPI bridge
[ 6.833094] usb 1-1.3: Manufacturer: JMicron
[ 6.833103] usb 1-1.3: SerialNumber: 9142CD7D6D72
[ 6.834117] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[ 6.834553] scsi host0: usb-storage 1-1.3:1.0
[ 7.924134] scsi 0:0:0:0: CD-ROM TSSTcorp CD/DVDW TS-H552D HP06 PQ: 0 ANSI: 0
[ 9.973649] initramfs: Checking for USB updates
[ 10.084561] initramfs: No USB device detected (when incorrect, try adding 'bootdelay=5' to your boot cmdline)
[ 18.711639] EXT4-fs (mmcblk0p3): recovery complete
[ 18.762043] EXT4-fs (mmcblk0p3): mounted filesystem with ordered data mode. Opts: (null)

 

Thanks in advance.

Hi,  when you click nanosound cd icon,  does jt it spin?

Which CD are you using and how do you power it?

 

Thanks

Hi. Yes it does spin for a while, then it complains about there not being any cd in the tray. I used ok computer and hail to the thief by radiohead, original cds. And I power both the Pi and the drive using an ATX power supply. It's an IDE drive connected to an IDE to USB adapter.

I also had an issue with DVD drive detection. We wanted to watch some old reality tv series during the x-mas holidays. Keeping Up with the Kardashians was on the top of our list. https://www.buzzfeed.com/raziameer/everything-you-ever-wanted-to-know-about-the-karda-e4zp36gign - Every family has that one crazy person in it, but this family is something special. Thank you for sharing the solution with us!