Forum

You need to log in to create posts and topics.

Apple Remote Control

Hi,

I would like to use the Apple (aluminum) remote control with the NanoSound DAC. Is this possible? Anyone used a remote other than the supplied Nanomesher branded one?

Thanks,

-K

Hello, NanoSound uses LIRC daemon so it should work with any remote.

The general steps to use another remote is

1) ssh to your volumio

2) Backup / rename the original nanosound remote definition (lircd.conf) and mapping file (lircrc) in /etc/lirc

3) Change to another lircd.conf / lircrc by replacing them.

4) restart volumio or nanosound plug-in

5) Test by using irw command then pressing the new apple remote, check if there are any outputs in ssh console

Assume your remote is modeled A1294, you may try these

https://github.com/volumio/volumio-plugins/tree/master/plugins/accessory/ir_controller/configurations/Apple%20Remote%20A1294

Let us know how it goes. thanks

 

Thanks for the info. I tried replacing the files but, it did not work.  For restarting LIRC, I was stopping and restarting the NanoSound plugin. (Also tried a reboot)

The IRW tool did not acknowledge the Apple (A1294) remote at all. I did validate that the remote is working (using the camera method). I also tried a few other Apple config files based on the LIRC remotes database but, no luck there either.  

Any other troubleshooting ideas? Is there a way to have IRW (or another tool) display raw codes from a remote? Currently, it only displays the remote that is configured and mapped via lircrc.

Thanks.

To debug into the raw code, try stopping the lirc service and run mode2 command like below

sudo systemctl stop lirc.service
mode2 -d /dev/lirc0

then try to press buttons in your remote pointing to NanoSound, you should be seeing codes showing on console.

If you can see the code, you can try to use irrecord to learn and create your own lircd.conf file

irrecord -d /dev/lirc0 ~/apple_lircd.conf

Follow the onscreen instructions, you might want to do all the keys like this

Once you can done with your apple_lircd.conf file, copy it to /etc/lirc

sudo mv /etc/lirc/lircd.conf /etc/lirc/lircd_original.conf
sudo cp ~/apple_lircd.conf /etc/lirc/lircd.conf

Restart nanosound plugin and try irw again

btw, A very good of LIRC here

Hope this helps

 

 

The JustBoom Remote Plugin should do it out of the box:

https://volumio.org/forum/remote-controller-feedback-thread-t6668.html

I am not able to get my remote to work either. I am running "IR Remote Controller (1.2.0) " configured for 'JustBoom IR Remote' using the remote
that came with my unit. I also have 'Nanosound by Nanomesher (1.1.5). System Version is '2.526 Released: San Jan 12. The LCD display
shows 'NanoSound v1.5.2'.

I did try the 'sudo systemctl stop lirc.service' followed by 'mode2 -d /dev/lirc0' - then pointed the remote right at the IR receiver on the
until while pressing buttons. The unit did not show that it had received any codes. Confirmed that the IR was working by filming via my
cell phone (can see IR) my pushing buttons on the remote (that came with the unit).

Next steps to resolve the problem on not having a  useful IR remote?

Kip

Hi.... any IR remote will work with the ATV4. Go into settings and the ATV will learn whatever buttons you want to use on the remote. If your TV remote has extra buttons that don't do anything you can assign those buttons to the ATV. Or, you can get a nice universal remote like a Logitech Harmony. I have the Harmony Hub with the basic remote that comes with it and it works great.